Flickr in WordPress Working Again!

Thanks to a tip from Donncha O Caoimh, I was pointed to the new FAlbum plugin for WordPress. It’s a handy Flickr-integration plugin that uses the new Flickr API – even works with my merged Yahoo.com account!

I’ve installed the plugin, and added it to the tabs again. It’s got some minor display funkery, where it looks like it’s not playing nice with K2 (or vice versa), but the plugin itself works great! It would rock if K2 added support for this one…

Anyway, it looks like FAlbum rocks quite nicely. There’s even a mature-looking admin screen in the WordPress admin side, as well! Thanks SO much to Donncha for the nice plugin!

Update: Excellent! Thanks to a tip on the K2 support forum, I was pointed to this page describing how to integrate FAlbum with K2. I’ll be playing with that over the weekend…

Update 2: Fine. I didn’t wait until the weekend to play with this. It took a whopping 5 minutes to get the bits hacked into place. Looks MUCH better now.

6 thoughts on “Flickr in WordPress Working Again!”

  1. [...] Update 2: Turns out I didn’t have to write that plugin after all. A MUCH better version was already under development. More info here. Flickr wordpress // Used for showing and hiding user information in the comment form function ShowUtils() { document.getElementById(“authorinfo”).style.display = “”; document.getElementById(“showinfo”).style.display = “none”; document.getElementById(“hideinfo”).style.display = “”; } function HideUtils() { document.getElementById(“authorinfo”).style.display = “none”; document.getElementById(“showinfo”).style.display = “”; document.getElementById(“hideinfo”).style.display = “none”; } [...]

  2. [...] This is driving me a little crazy … I’ve been trying to get the FAlbum plugin working in WordPress and I can’t get it going. I was all excited when I saw that D’Arcy said it was so easy … hmm — user error I guess on my end. I have been following some great directions over at andreaslinde.de … seems so easy, but I keep getting an error when I try to place it on a WordPress page. Works fine when I leave the file in the default location. Just doesn’t want to work. If you want to see what happens, click the Photos link in the header. Any advice from the smart people out there. Help! [...]

  3. I’ve gotten the plugin installed no problem but for some reason the photos are all very small (unviewable) sizes – any ideas for this?

    Thanks! Eli

  4. Yeah – I had the same issue when I upgraded K2 to r96 – but following the instructions on that page (and nuking my browser cache to get rid of the older css files) did the trick for me.

Comments are closed.